Operational from 4:54 AM to 4:54 AM, Major outage from 4:54 AM to 4:56 AM
Updates
Resolved
UTC
Resolved
UTC
HL Clinic is back up. This incident was automatically resolved by Instatus monitoring.
Investigating
UTC
Investigating
UTC
HL Clinic, HL Clinic, HL Clinic, HL Clinic, HL Clinic, HL Clinic, HL Clinic, HL Clinic are down at the moment. This incident was automatically created by Instatus monitoring.